Gradience Attendance Pro / Enterprise - Time-Off: Remedy for Custom Dates Exhausted

Custom Dates Exhausted

When you try to accrue, you get an Accrual Pre-run message. In the report, one or more names will appear with a line of text reading:

Custom dates exhausted for plan (name of Time-Off Plan)

Cause: 

You  have run out of Custom Dates on which employees may earn Time-Off

Solution:

1. From within the program, select an employee whose name appeared on the report.

2. On the left, click Time-Off Assignments. Over toward the right, notice the Time-Off Banks listed in the shaded column. In the next column, you will find the name of the Time-Off Plan for which the report said the custom dates are exhausted.

When you set up a Time-Off Plan to accrue on Custom Dates, the number of custom dates applied is a finite number, not an infinite number. This Time-Off Plan has apparently run out of dates on which to accrue.

3. Click Settings > Time-Off Plans. When the Plan List popup window opens, select the plan that was mentioned in the report and click the Plan Setup button.

4. Now go to the lower left to the section called Select How Often to Accrue. Click the Edit Custom Dates button. If the Edit Custom Dates button is grayed out, click Yearly – once per year and then click Custom. You can now click the Edit Custom Dates button.

5. When the Custom Dates Entry popup window opens, you will see that The Frequency is already set to Every Two weeks (26 entries)

IMPORTANT! This is not a representation of how you had previously set it to accrue. It is the default setting each time you open this screen. Reset it to the proper frequency if your frequency is different.

Custom_Dates_Exhausted.png

6. Go to the vertical field showing dates in the middle of the screen and scroll down to the last date. That is the last time this plan has been designed to accrue Time-Off. To allow it to accrue beyond this date, you need to add more dates.

Note:

  • If you are using one of the options available under Frequency on the left, move on to step 7.

  • If you are not using one of the convenient frequency choices available, you may manually enter dates into the vertical field in the center of the screen. To do so, click on the last date in the field and press the Tab key on your keyboard. Then manually type-in the date. The last date entered is the last date when Time-Off will accrue to employees.

7. Enter a new Start with Date that would be the next date Time-Off should logically accrue to employees. In the area where it indicates Number of dates to add, Change 52 to whatever the correct number of dates Time-Off should accrue until your license expires. The number you enter must  including the Start with Date.

IMPORTANT! You can only enter dates for the [licensed year]. Once you purchase the next license, you may enter dates for that year.

8. Click Run Autofill. This will populate the central, vertical window with the rest of your custom dates until your license expires.

9. Click Save >Exit. The Custom Date Entry popup will close. Now click Save on the Plan Setup screen to save the plan as a whole and exit.

10. Now attempt to accrue again.

 

 

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